вторник, 3 апреля 2012 г.

Баг в Adobe flash под linux (цветопередача)



На днях сделал yum update, и был неприятно удивлен. На youtube.com (и только на нем!) возникли проблемы с цветопередачей. Видео начало очень напоминать кадры из фильма "Аватар" - те же синие лица :(

Гугление показало, что проблема не только у меня, множество жалоб после обновления. Проблема наблюдается как под Firefox, так и под Chrome.

Собственно, можно решить проблему, переключившись на youtube на HTML5 ( http://youtube.com/html5 ), но как-то этот новый режим работает не очень устойчиво ( у меня видео зачастую просто не воспроизводилось).

Рецепт (проверенный), как починить:

# mkdir /etc/adobe
# cat > /etc/adobe/mms.cfg
EnableLinuxHWVideoDecode=1
OverrideGPUValidation=true


Т.е. создаем файлик /etc/adobe/mms.cfg с указанным выше содержимым. Перезагружать бровзер мне не потребовалось.

6 комментариев:

  1. Благодарности ^_^

    ОтветитьУдалить
  2. Не за что :)
    за последний месяц адобю сначала починил багу а потом снова все сломал :(
    Но самое противное, что под файрфоксом у меня сейчас флеш постоянно валится :( - и сделать ничего не получается

    ОтветитьУдалить
  3. Интересно, это намеренная атака на линукс?
    Или же банально все тестеры были только под винду?

    ОтветитьУдалить
  4. Прикол еще не весь.
    Бага проявляется только и исключительно на youtube....
    Но, стоит с ютуба сделать embed, к примеру, на форумную страничку - все работает.

    PS. После обновления на 13го firefox и переинсталляции flash (провел сегодня) - вроде как работает устойчиво. Будем посмотреть

    ОтветитьУдалить
  5. Спасибо помогло после рестарта хрома. Вобще неожидал такого расклада.. думал монитор накрылся))

    ОтветитьУдалить
  6. Нажмите правой кнопкой мыши на окне ролика в настройках выбирете отключить аппаратную поддержку .. все !

    ОтветитьУдалить